Installing FreeBSD on my newly built server

Ahhh… I have two computer screens in my room. Now it positively looks awesome. Also, my room is 10 degrees warmer than the rest of the house and there is a gentle roar from the many cooling fans. Well, it proved to be quite a task setting up this machine. Not that it was hard, but I ran into a lot of “issues”.

First, I found out that my processor from my old piece-of-crap HP was that slot kind – the kind that SUCKS. So I had to go get a new processor. Turns out they were out of Pentium III’s. Nobody stocks them anymore. So I had to return my old board, and get a new one. I also had to get a new processor – a Pentium IV @ 1.7 GHz. I thought I’d replace the 1.4GHz I have on my alienware machine, but it turned out that the board was different. But then trouble started.

I put the (old) processor back and the PC wouldn’t start. After 3 frustrating hours, (I fell asleep for like 30 minutes) and due to help of a few of my friends (Gouri and Suraj), the problem was traced to some bent (ouch!) pins on the processor. Finally, we got the processor seated right and my system was good to go. I also sliced my finger open in the process. Oh yeah, don’t trust the manuals. They tell you to put the processor a certain way, but that way is WRONG. Either that or my stupid processor had the dot in the wrong place. How lame is that?

Next, I had to put my server together. It was pretty easy. It started up on the first try. But the HDD and Power LEDs weren’t lighting up. I followed the directions on the mainboard manual, but apparently they were wrong (yet again!). So I connected it my own way and it worked.

I booted up with FreeBSD without any issues. I ran into problems when it said “Write failure on transfer (-1 bytes written 26404 bytes)”. I was like WTF? So I restarted it and tried doing it over again – same result. I searched on Google and some one said they had traced the issue down to the CDROMS. I have my old HP CD-ROM and CD-RW. I was booting off my CD-R so I switched it over the CD-RW. Worked fine! 🙂 Of course, I still have to set up my network… That should be interesting. I’m gonna have Marc help me out…